注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Puriney's Notes

Puriney=purine+Y, my Wonderland

 
 
 

日志

 
 

【ubuntu】gvim安装以及将vim/gvim打造为perl的IDE  

2012-03-01 13:46:05|  分类: UBUNTU |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
众大神不要喷我,神器vim/gvim竟然被我用来写脚本流perl,而且还很自high地打算专门打造为perl的IDE。原谅我吧~~~原谅我不满足于使用gedit 或者geany的欲望吧~~~
不过跟我有同样想法的人,不止我一个,因为有专门达成我这样目的的插件——perl-support.vim[1]

gvim安装
按照时间顺序还是先扯如何安装gvim,就是更多图形化支持的vim,堪称神器。安装的时候很简单,但是如果启动gvim时遭遇了这样的错误:

 (gvim:10922): Gtk-WARNING **: Invalid input string
(gvim:10922): Gtk-WARNING **: Invalid input string
Vim: 拦截到致命信号(deadly signal) SEGV
Vim: 结束。

原因: Ubuntu 10.04 Lucid Lynx默认安装将会把中文区域设置为zh_CN.utf8,而GVim能识别的中文区域设置为zh_CN.UTF-8。因此GVim会在启动时报错,且无法正常加载中文菜单。
解决方案,代码:

 cd /usr/share/vim/vim72/lang
 sudo ln -s menu_zh_cn.utf-8.vim menu_zh_cn.utf8.vim

此方法使得GVim可以识别zh_CN.utf8,并采用于zh_CN.UTF-8完全相同的菜单设置。并且不影响系统的中文区域设置。【2】

安装perl-support.vim
1. 下载插件(到随你想放置的位置,这里以/tmp为例)

cd /tmp
wget http://www.vim.org/scripts/download_script.php?src_id=17460

这里下载地址在官方网站里,本文写于2012年3月1日,所以下载的版本是2012年2月14日情人节特别版4.15版本(当然噱头是我瞎扯的)。时间推移且内容更新时,请读者自己注意下载相应最新的插件。

2. 安装

mkdir ~/.vim
cd ~/.vim
unzip /tmp/perl-support.zip

如果没有 ~/.vim 就自己 mkdir 一个。

3. 在.vimrc内启动该插件
vim的.vimrc文件在哪里?我的ubuntu 10.04.3 在 /etc/vim 内,所以在此处编辑就好。至于其他的,要么直接在你主文件夹下,要么就在/etc 里。

vim /etc/vim/vimrc
filetype plugin on

这样,就成功开启了该插件。有了该插件之后写起来perl来会更方便一些(或者更装11一些)。
【ubuntu】gvim安装以及将vim/gvim打造为perl的IDE - Puriney - Purineys Notes
 
p.s. 高亮主题是inkpot。

更多热键可以参考官方文档(很短),http://lug.fh-swf.de/vim/vim-perl/perl-hot-keys.pdf ,熟悉使用后确实可以很好地装11.

--话外音
实在是要感激我们lab宽松的环境,让我在等转化的细菌摇起来等着送去测序时,可以来折腾折腾我喜欢玩的东西。本文是比较低端的入门文章,更多好玩的资讯不妨参考其他专业vim的blog [3]

-- end &&reference

  评论这张
 
阅读(3232)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017